Post

6 followers Follow
0
Avatar

DJI P3A Firmware Issue in Commander

Dear Skycatch,

What a wonderful app that would be very usable at my location here in Sungailiat, Indonesia. I'm using Ipad Pro 9.7", drone firmware 1.9.60 (released on June 13th, 2016).

But when I started Commander with everything connected as instructed, Commander shown this dialog: "Your drone's firmware (1.1.5+) needs to be updated to at least 1.6.0040. Please refer to https://developer.dji.com/mobile-sdk/downloads/ for downloads and how-to guides You will be able to continue planning your flight, but will not be able to take off."

I already go to the DJI Developer site and there's nothing there that relates to my issue.

Please help, so that I can try your product right away.

Thanks.

Rgds,

Mark

 

 

Mark Rompies

Please sign in to leave a comment.

2 comments

0
Avatar

Hi Mark - thanks for your post and your feedback, we really appreciate it! The incorrect firmware message is currently a bug that our engineers are working on fixing for the next release. If you've confirmed that your drone and RC firmware are up to date, you should be able to close out the error message and continue planning and flying your mission. 

Apologies for the inconvenience! We hope to release the next version with the fix very soon. If you are still running into issues, please feel free to email us at support@skycatch.com for further troubleshooting. Happy flying!

Sylvia C 0 votes