Follow

What Drones are Compatible with Skycatch Flight App?


Currently the following DJI drones are supported with the Skycatch flight app: 

  • Phantom 4 Pro
  • Phantom 4
  • Phantom 3 (Professional and Advanced)
  • Inspire 1, Inspire 1 Pro (Zenmuse X5 and X3

These drones can provide you with excellent accurate data. We're in the process of updating the app and compatibility with other drones, such as the Inspire 2, Mavic, and Matrice 100, so please stay tuned!

Please note: the Skycatch flight app is not currently compatible with the DJI A3 controller or the CrystalSky monitor as DJI does not allow non-DJI apps on the tablet they provide with their remote controllers. However, if you wish to use the Skycatch Flight app, you can detach the DJI tablet and connect your own iOS device to download and use our app.

Was this article helpful?
0 out of 0 found this helpful
Have more questions? Submit a request

Comments

Powered by Zendesk